MongoDB版本兼容性

Mongoose依赖MongoDB Node.js驱动和MongoDB的交流。你可以参考这个表的最新信息以MongoDB驱动程序支持哪个版本的MongoDB版本。

下面是semver范围代表哪个版本的mongoose与MongoDB服务器版本兼容。

  • MongoDB Server 2.4.x: mongoose ~3.8, 4.x

  • MongoDB Server 2.6.x: mongoose ~3.8.8, 4.x

  • MongoDB Server 3.0.x: mongoose ~3.8.22, 4.x

  • MongoDB Server 3.2.x: mongoose >=4.3.0